Houd de updates in de gaten!

  • 10/01/2018

De wereld loopt gevaar. In ieder geval de technologische wereld. Begin dit jaar werd namelijk duidelijk dat vrijwel alle computersystemen en mobiele devices het risico lopen om gehackt te worden. Zorg dus dat je zo snel mogelijk beschikbare beveiligingsupdates installeert.

‘This is NOT a drill, people’; een gevleugelde uitspraak die een groot gevaar aanduidt. Wat mij betreft is deze uitspraak op dit moment waarheid. Begin januari werd bekend dat vrijwel alle moderne chips van Intel, AMD en ARM een beveiligingslek hebben. Deze chips zitten in vrijwel alle computers, serversystemen en mobiele Android en Apple devices. Met andere woorden: bijna de hele wereld loopt een risico.

Spectre en Meltdown

De nieuwe risico’s heten Spectre en Meltdown. Beide hebben betrekking op een proces in de chip dat ‘speculative execution’ heet. De processor zoekt op voorhand naar een bepaalde waarde die het verwacht op basis van de opdracht die het krijgt. Is deze waarde niet nodig, dan slaat de processor dat tijdelijk op in het cache geheugen, mocht het later nog wel nodig zijn. Daarna gooit de processor de waarde weg. Zowel Spectre als Meltdown kunnen deze ‘verwachte’ waarde inzien en zo toegang krijgen tot informatie. Als een inbreker dit doet bij een chip op een serversysteem, kan hij zo toegang krijgen tot alle clouddiensten die op die servers draaien. 

Patches

Met man en macht wordt gewerkt aan patches om de risico’s tegen te gaan. Voor Meltdown zijn er inmiddels al verschillende patches. Apple heeft voor zowel computers als mobiele devices patches gepubliceerd en ook Android heeft patches in de maandelijkse updates opgenomen. Intel, een van de chipbouwers, verwacht nog deze maand de verschillende patches uit te rollen.
 
Voor Spectre zijn er nog geen beveiligingsupdates beschikbaar. Dit heeft ermee te maken dat Spectre zicht niet alleen op het geheugen van de chip richt, maar ook op onderlinge processen. Daardoor is het veel lastiger om een patch te creëren. Daarbij moet wel gezegd worden dat een aanval met Spectre veel lastiger is uit te voeren door hackers. 

Altijd updaten!

Al eerder hebben we het belang van patches en beveiligingsupdates benadrukt. Zorg dat je altijd de laatste versies hebt. Voor deze aanval is het misschien nog wel belangrijker, omdat het om een aanval op hardware gaat. Want de hardware heb je niet zomaar vervangen, zeker niet op een schaal van deze grootte. 

We zullen de komende jaren nog last hebben Spectre en Meltdown. Tot die tijd zullen we moeten blijven letten op verdachte zaken in onze netwerken en websites/webapplicaties. De ThreadScan helpt hierbij: deze wordt continue bijgewerkt om te waarschuwen bij kwetsbaarheden in systemen. Daarnaast moeten IT-ers hun systemen blijven updaten met de laatste patches. Alleen zo kunnen we ervoor zorgen dat Spectre en Meltdown zo min mogelijk schade kunnen aanrichten


Terug naar overzicht